Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 26, 2026 - 04:00 EDT
Scheduled
We will be performing scheduled maintenance on our Superior cluster to increase available system resources. This upgrade will improve performance and stability for all sites hosted on this cluster.
This maintenance requires a server reboot, so websites hosted on the Cluster will be temporarily offline for a few minutes during the maintenance window. No action is required on your part. All sites will return to normal automatically once the cluster has restarted.
We have scheduled this work during off-peak hours to minimise any impact. Thank you for your patience.
Posted Jun 25, 2026 - 21:25 EDT
This scheduled maintenance affected: MONTREAL DATA CENTRE.