Migration to New Status Provider

Incident Report for WPCloud

Resolved

This incident has been resolved.
Posted Feb 06, 2026 - 16:17 EST

Investigating

We have moved our status page to this new platform because our previous status page provider is shutting down their operations.

You can view our live status here: https://wpcloud.statuspage.io/

Since the old provider is closing, we had to export our data to preserve it. You can view the full archive of our past incident history here: https://wpcloud.ca/history/
Posted Feb 06, 2026 - 16:17 EST
This incident affected: WPCloud Status Page Provider.