BRANNEN Database Issue

Incident Report for WPCloud

Resolved

Server is back to normal response levels.
Posted Jun 24, 2026 - 19:28 EDT

Investigating

We are investigating an issue impacting the BRANNEN database server.
Posted Jun 24, 2026 - 19:23 EDT
This incident affected: MONTREAL DATA CENTRE.